07-13-2026 Incident

Incident Report for BigID

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 11:26 UTC

Update

We are continuing to investigate this issue.
Posted Jul 14, 2026 - 10:00 UTC

Investigating

We are currently investigating performance degradation affecting one of our clusters.
Posted Jul 13, 2026 - 10:46 UTC
This incident affected: BigID Cloud (US East Region (Northern Virginia)).