09-09-2025 Incident

Incident Report for BigID

Resolved

This incident has been resolved. Services are fully operational.
Posted Sep 10, 2025 - 04:52 UTC

Investigating

We are aware of and actively investigating reports of slowness and connectivity issues with BigID. You may experience slower load times or difficulty logging in.

Our team is working to identify the root cause, and we will provide an update as soon as we have more information. We appreciate your patience as we resolve this issue.
Posted Sep 09, 2025 - 19:52 UTC
This incident affected: BigID Cloud (US East Region (Northern Virginia)).