Intermittent Connectivity Issues

Incident Report for BigID

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 04:22 UTC

Investigating

Users in US-East are experiencing connectivity issues. We are working to restore full functionality.
Posted Nov 19, 2025 - 00:06 UTC
This incident affected: BigID Cloud (US East Region (Northern Virginia)).