18-05-2026

Incident Report for BigID

Resolved

The incident has been resolved.
Posted May 19, 2026 - 12:11 UTC

Identified

The root cause has been identified, and we are working on a fix.
Posted May 19, 2026 - 00:25 UTC

Investigating

Some Privacy Portal tenants may be unable to access the Privacy Portal UI. Submitting requests and all backend features are unaffected. Customers can also access from their standalone Privacy Portal platform
Posted May 19, 2026 - 00:25 UTC
This incident affected: BigID Privacy Portal.