Degraded Performance: us-east-1 region

Incident Report for BigID

Resolved

All Systems Operational: Following the recent AWS disruption, all services have been restored and are functioning as expected.
Posted Oct 20, 2025 - 22:43 UTC

Monitoring

We recently experienced a temporary service disruption due to a global AWS issue in the us-east-1 region.
We are seeing significant signs of recovery, and our team is closely monitoring performance and stability. Other regions and environments remain operational.
For real-time updates from AWS, please refer to their AWS Status Page - https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 10:07 UTC
This incident affected: BigID Cloud (US East Region (Northern Virginia)).