03-09-2026 Incident

Incident Report for BigID

Resolved

This incident has been resolved.
Posted Sep 10, 2026 - 19:42 UTC

Monitoring

A fix has been applied, and we are currently monitoring the results. We will provide another update once we have confirmed that the issue is fully resolved.
Posted Sep 09, 2026 - 18:39 UTC

Identified

The issue has been identified, and our team is actively working to implement a resolution.
Posted Sep 07, 2026 - 08:22 UTC

Investigating

We are currently investigating performance degradation affecting one of our clusters.
Posted Sep 03, 2026 - 13:20 UTC
This incident affected: BigID Cloud (US East Region (Northern Virginia)).