07-10-2026 Incident

Incident Report for BigID

Resolved

This incident has been resolved.
Posted Jul 11, 2026 - 09:51 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.

We will provide the next update by 04:00 UTC.
Posted Jul 10, 2026 - 18:10 UTC

Investigating

We are currently investigating performance degradation affecting one of our clusters.

Our team is actively looking into the issue and will provide the next update by 20:00 UTC.
Posted Jul 10, 2026 - 17:39 UTC
This incident affected: BigID Cloud (US East Region (Northern Virginia)).