21-07-2026 Incident

Incident Report for BigID

Resolved

The issue affecting Cloud customers has been resolved. We implemented a fix and confirmed that services are operating normally. We will continue monitoring to ensure stability.
Posted Jul 21, 2026 - 19:01 UTC

Investigating

We are currently investigating an issue affecting Cloud customers. We will provide another update by 19:00 UTC.
Posted Jul 21, 2026 - 17:25 UTC
This incident affected: BigID Cloud (US East Region (Northern Virginia)).