22-07-2025 Incident

Incident Report for BigID

Resolved

The issue affecting user interface performance has been successfully resolved. A fix was implemented, and system performance has returned to normal. As of 00:00 UTC / 03:00 IDT, the incident was fully mitigated.
Posted Jul 23, 2025 - 06:16 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 22, 2025 - 17:56 UTC

Identified

We are currently investigating reports of slowness within the user interface. Some customers may experience slower load times or pages not loading correctly. We are actively working on a resolution and expect a fix to be implemented in the coming hours. We appreciate your patience as we address this
Posted Jul 22, 2025 - 17:51 UTC
This incident affected: BigID Cloud (US East Region (Northern Virginia)).